Embed Code Editor not functioning

Anyone else having problems getting the HTML Embed Code Editor to work for custom code (ads/ gifs, etc) today? It worked fine last night and this morning all new and edited embed codes are not displaying. I can put the code in, save & close it, but when I go back the code is gone. We do 2-12 of these on all our pages and it has always worked fine until now. Help!

Screen Shot 2020-04-14 at 2.44.01 PM|641x500

Hi there,
Thanks for reporting this issue. We are investigating further.

I’m having the same problem since yesterday. The HTML embed code editor is not working at all. I’m using both CMS and Ecommerce blogs and it’s not working on either one of the publications.

1 Like

The editor it’s not working only in CMS or Ecommerce pages. If inserted directly from add components tab, works perfect.

Hi there @erinCS and @itos ,

Thanks for your patience while our team identified the cause of this issue. A fix has been deployed and I have tested on one of my projects to confirm it is now working.

Please check again for adding custom code in your CMS items and let me know if any further issues.


Yes, it’s working fine now. Thanks!

Has this issue come back @david_T ?

HTML Embed Code Editor seems to work on static pages, but all my embeds have disappeared from all my CMS pages. They were definitely there yesterday!

Exact same Embed, the first on the CMS, the second on a static page:

How it should look:

@radicalrooster The previous issue related to custom code not saving in the rich text field. That issue has been resolved.

Your screenshot looks like the code is showing in the inspector, however the div iframe is not loading any width and height.

If you share a readonly link to the project, or published page then it might help to check further.

@david_T I solved the issue by manually styling the Div and setting width and height to 100%.

It wasn’t a custom div, just the standard HTML embed used in the CMS editor which is odd.