Editor Option Breaking Javascript

I never use the editor, I am always in the designer, but recently I was showing a team member how to use it. Every since then the editor option appears on the lower right corner of the window. I have logged out and it remains.

While annoying that I can’t make it go away, the real problem is that I am implementing custom javascript and this element is throwing a warning in the console that is stopping my javascript from working properly.

I am using Edge [version 109] (as the designer seems to work best in this browser). I can bypass this issue by previewing my site in a private window, but it would great if this bug would get resolved or I could turn off the editor option.

My custom charts are working, however it breaks Finsweet Attributes.

I think that Webflow works best in chrome. In chrome that issue doesn’t exist so maybe worth reconsidering choice of the browser. You’ll still be unable to render JS while in preview mode but at least it won’t stay logged in/active after logging out

Hey Marko, thanks for your reply. I have been using Chrome for years, but as part of the “Logic” beta program, I have experienced some recent crashes in Chrome and just recently moved to Edge to avoid those issues. FYI, I know that JS does not render in preview mode. I am rendering the site using the staging domain to preview.

@marko-ninja - FYI: MS Edge (current builds since Jan 2020 ) is based on Chromium, the same engine as Chrome. There should be absolutely no rendering difference between Chrome, MS Edge, or Brave per platform. The difference that would potentially affect users is the default settings on the blocking of tracking scripts. I work almost exclusively in Brave with zero issues using Webflow day to day. Of course, your mileage may vary.