Streaming live at 10am (PST)

Editor - Changing link block inside symbol, doesn't update anywhere

Hey guys,

My client tried to edit a link block in the footer section of his website. This footer is a symbol and should change everywhere else right? After confirming the change, the link reverts back to what it was before.

Any thoughts?


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hi @Davidlin_ch12

Can you please try editing the link once more, then press CMD+S (Ctrl on windows) to manually save the change?

Then let me know if it reverts as it did before. ​Thanks in advance!

Hi Brando, we tried doing this and the problems still persists. We are using the latest Chrome version

Hi @Davidlin_ch12

Thanks for letting me know.

I did some testing on this end using these steps:

  1. Double click into the footer symbol
  2. Select a footer link
  3. Change the link destination
  4. Press CMD+S
  5. Publish
  6. Test live site — works as expected

Can you please try taking these steps once more — If you are seeing other behavior on your end, can you send me a screen recording of what you see? CloudApp or Quicktime work well.

​Thanks in advance!

Hi Brando
Sorry for the late reply

The problem is happening inside of the Editor, not the Designer.
We try to change a link in the Editor by clicking the link icon, typing in the link and saving the change by clicking on the checkmark.
When visiting the public site, nothing has changed and going back to the Editor shows the old link again.

I have prepared a video for you: https://cl.ly/b28289768d14
In the video I try to change the link to only www.instagram.com, but going to the public site, it shows the old link.

Thanks for your help @Brando, we appreciate it :smiley:

Hi @Davidlin_ch12

Thanks for clarifying and for sharing that video — very helpful in seeing the issue!

So right now there is a known issue in the Editor that the team is working to resolve. The issue is that changing a link will not prompt the publish button. In this case, the change would need to be published before logging out in order for it to go live.

The team is working to resolve this issue though, and I’ll be sure to post back here when I have new info for you :bowing_man:

1 Like

Thanks a lot @Brando :smile:

We look forward to the fix and wish you and the team a merry Christmas.

1 Like

Hi, client’s of mine are having the same issue :slight_smile:
They want to edit links in symbols (links in the footer for example) and the editor doesn’t want to save or publish those changes.

Any ETA on a fix ?

No solid timeframes yet on this one, @pepperclip :bowing_man:

Ok, I hope you guys will find some fix.

Until then, happy holidays !

1 Like

Hi @pepperclip @Davidlin_ch12

​Thank you again for posting out about this issue in the Editor.
​I wanted to let you know our team was able to push a fix and you can now save and publish link changes using the Editor! :tada:


3 posts were merged into an existing topic: Editing links in editor mode is not registered as change for publish and not saved

Hi @Brando,
Here’s the link of the concerned project : https://preview.webflow.com/preview/mk-2019?utm_source=mk-2019&preview=463fdd92acb10abc347713310e23288f
But the problem is in the editor / not in the designer…

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.