Streaming live at 10am (PST)

Discount code apply button not working on desktop


I am having issues with my client’s website regarding the checkout (Paypal) page. Whenever I press the apply button in the discount box the discount that I had set for them doesn’t seem to work/apply.

This problem doesnt seem to affect mobile but is persistent with the desktop version.

Feel free to try and apply the code LOCAL prior to placing order. The function is supposed to give out free shipping but it doesnt do anything.
Again, it works on mobile but not desktop.

Here is the read only link btw

make a test discount code for 100% off but don’t ship anything with the test code, I won’t let me make one to test in the readonly link

Thanks for replying! Could you elaborate a bit more on what you want me to do?

@Rani_Sofya The code LOCAL is live and should give a discount on the shipping for 100% off

and that’s the one not working?

Yes, it only works on mobile for some reason but not on desktop.
Try to visit on both mobile and desktop and try to checkout a product but dont hit place order. Just apply the code.

ok so I can’t do it on either one because you buy directly from the bag rather than a checkout page

The bag is only there to collect information for billing and shipping but it doesnt place order. You can hit continue and it will take you to the checkout page before you can place order. There you’ll find the discount box to test code LOCAL

and only PayPal on desktop doesn’t work right?

Yes thats correct. Mobile works fine

Does it usually say invalid code or it just disappears?

@paulgonzales cuz tbh it doesn’t even give me shipping options, can you give me a code that’s like 1% off total order, I’m in Canada and it says that you don’t ship there anyways

I added TESTCODE for 1% off go ahead and try it
It usually just takes off the shipping when in mobile but in desktop the button doesnt do anything.

I see, try deleting the discount code element and re-adding it, that’s really strange. It seems to not work on tablets either and I checked if the settings are different on the mobile and on the desktop but they’re the same, sometimes when you publish the site, it doesn’t publish properly, the same thing happened with me but with an entire page and I had to remake the whole page for it to start working. It’s most def a bug in Webflow, maybe @PixelGeek or another mod would be able to bring it up to the backend devs.

It was actually called LOCALPICKUP when the issue started so then I tried deleting and creating a new one called LOCAL but still no dice.
The webflow support told me to disable and enable but same thing, nothing happened.

Yeah I think you’re gonna have to either redo the page or someone from support will have to investigate the bug further.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.