Disable all responsiveness except desktop

Hey guys,

I’m doing a website just for Facebook Messenger’s webview. That means, that it will always be mobile, but our specific window will always have a desktop-ish ratio - as seen in this screenshot, my window is the white area:

I am happy so far with what I’ve designed in the desktop panel - it’s responsive and on a good way. I used desktop, as it has the right ratio for that project. Anyway, it’s always mobile, so webflow switches to fullscreen mobile and that screws up the entire design.

Ist there a way to disable all modes except for desktop or/and to determine, that the desktop version is used in every case?

Here is my public share link: LINK
(how to access public share link)

Hey you can use a custom code in the section like this;

body, html {
  min-width: 1200px !important;

Let me know how it goes.

1 Like

Thanks a lot!
How do I insert the code? Does that also work without having webflow’s paid version? Does it also work when there’s no section, just a slider, column and div blocks?

Hey Johannes. You need a subscription for custom code.

Alright thanks Alex. Thinking about purchasing that. So I’ve heard that webflow decides whether to treat your page like desktop, tablet or mobile based on pixels. Any way to make it treat any pixel size like desktop? (same question, other way of saying it. I can’t code, so I might sound confusing lol)

Actually you don’t need custom code. Just put a regular div or section in the body, give it a unique class, and set minimum width via the designer. Then everything goes inside it.

Alternatively, if you have access to custom code, you can set this in Site Settings > Custom Code > Header Code http://stackoverflow.com/a/31334640/584192

1 Like

Thanks a lot!
We’re making great progress at that site and are tweaking a lot of div blocks and other stuff to come closer to the perfect solution.
The thing with your solution @samliew and @AlexManyeki, it makes the page scrollable sideways below a certain width and we don’t want that. Anyway, we found some other ways that are shaping up to be promising :slight_smile:

perhaps you can add;

overflow-x: hidden;

to the code I had given you earlier.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.