Streaming live at 10am (PST)

Designer seems laggy?

today after a long session working on my projetc the designer started to lag quiet a bit.
I reload the website, relogged and switched devices (from my MacBook to my PC) and nothing worked. Now the designer in my other projects started to lag too…

Here is my site Read-Only: Link

Does anyone else currently encounter similar problems?

Same problems here too, impossible to do anything!

1 Like

Thankfully someone else is having the problem… I thought I get insane

Yup, same thing here… What’s weird, is, that scrolling is extremely slow and sluggish, but when I click on a text field or paragraph in order to type something, scrolling suddenly seems fine. Hope they fix this soon.

Have you tried logging out and in again, since they’re pushing fixes today?

Hello :wave:

As @ElviraNL mentions, we have pushed some fixes. Please try logging out and back in again, and empty your cache to see if this helps.

If you’re still having issues, please do post back, and where possible share your screen recordings and/or read only links. :webflow_heart:

Hi @magicmark,

problem still persists unfortunately. Here’s a screen recording: (Framerate is low, so you can’t see it very well, but as stated before: scrolling ist slow, both when designing and when preview is active. But when a text field is double clicked and focused, scrolling is fine and smooth.)

Here’s my read-only link:

And yes, I tested it with different browsers, incognito mode and with different projects via the showcase. Same thing. :frowning:

Hope you can help.
Thanks in advance. :slight_smile:

Hey @magicmark,

I made another video. Hope the problem gets clearer there:

So what happens exactly?
When scrolling in the Designer – both in edit and preview mode – the whole thing ist really slow and laggy. This happens to me in every project in my account and when opening other projects via the showcase — both when I’m logged in in my account and logged out. I tried different browsers, clearing website data, cookies and cache, logging off and on again, different Macs and different networks — same issue.

It only happens in the Designer, not in the Editor. And in the Designer it only happens when an element on the page is selected or none is selected. If I double click a text field in order to edit it and then try scrolling, it feels normal. And as you can see in the video, when I scroll and a text field is selected (cursor blinking), no error is being recorded. But when scrolling without selecting a text field error logs are generated all stating: [Violation] 'requestAnimationFrame' handler took 167ms or 267ms and so on:

designer.13a5d5339275ddc9506b.chunk.js:1 [Violation] 'requestAnimationFrame' handler took 139ms
designer.13a5d5339275ddc9506b.chunk.js:1 [Violation] 'requestAnimationFrame' handler took 136ms
designer.13a5d5339275ddc9506b.chunk.js:1 [Violation] 'requestAnimationFrame' handler took 131ms
designer.13a5d5339275ddc9506b.chunk.js:1 [Violation] 'requestAnimationFrame' handler took 131ms
designer.13a5d5339275ddc9506b.chunk.js:1 [Violation] 'requestAnimationFrame' handler took 54ms
designer.13a5d5339275ddc9506b.chunk.js:1 [Violation] 'load' handler took 441ms
designer.13a5d5339275ddc9506b.chunk.js:1 [Violation] 'setTimeout' handler took 186ms
[Violation] Forced reflow while executing JavaScript took 43ms
designer.eb86cf70bc4132905780.chunk.js:1 [Violation] 'setTimeout' handler took 144ms
[Violation] Forced reflow while executing JavaScript took 117ms
designer.eb86cf70bc4132905780.chunk.js:1 [Violation] 'setTimeout' handler took 100ms
[Violation] Forced reflow while executing JavaScript took 102ms
content.js:52 [Violation] Added non-passive event listener to a scroll-blocking 'touchstart' event. Consider marking event handler as 'passive' to make the page more responsive. See

This all started yesterday around 4:15 PM GMT. I’m located in Germany I should add.

Anyways, I hope you can help me and others with this.

Kind regards,

1 Like

Can confirm, I’m encountering the same ‘requestAnimationFrame’ handler violations.

1 Like

I have the same problem here…

Same here. This and the cmd+z bug renders Webflow impossible to work in :tired_face:

1 Like

Hello Everyone,

We have identified the issue and will be rolling out a fix shortly.



Same problem! Hope you fix it soon

The problem is gone here :slight_smile: Thanks so much!!!

Problem solved. Thanks. :+1:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.