Deleted content in a CMS page, still linked but not showing up

I am a definitely a Webflow noobie and made a big mistake last time I worked on my portfolio that I now need to change.

The problem: At one point I deleted the content on one of my CMS pages, but I can see that all the layers in the inspector are still present and it is still linked to the CMS portfolio collection.

I tried to resolve this by copying sections from the other pages and pasting it into the one that is now empty but that causes duplicates on the other pages.

I am hoping to get the content from the CMS to show back up in the empty page so I can have it re-populate from the CMS. Or delete the page and get a new page in its place.

This is what the empty page looks like, everything has been deleted out but you can still see content in the inspector.

Appreciate any help!

Here is my public share link:

Hey Katelyn! To resolve the issue, log in to the CMS and navigate to the page in question, select all layers associated with the page, delete them, save the changes, and check the page it should work.

Welcome @katelyn_Dacus :wave:

If I’m getting the url correct, the page 404’s on the live site:

When I look at your linked page in the Designer it says it’s archived:

And then in the CMS it says staged, and not published:

So I am assuming you are inspecting from within the Designer and not the live site?

If so, that makes sense. Your designs in a CMS template should always show up. In most cases so will your content even if it’s not published, but it never should on the live, published site.

Beyond that, I do (at times) see a flash of content in preview mode. Digging into the navigator I see some interactions that show elements when scrolling into view. They set a 0 opacity. This could also be contributing to your issues if I’m totally off with what I mentioned above.

Does that clear things up?

Yes, but I actually archived that case study “Acuview Pulse” because the content wasn’t showing up on it anymore anyway. I was afraid to delete the page so I decided to archive it. From my live site I’m not sure how to get to the page that has the error because there is actually no way to navigate to it from the home screen.

I tried to get a new page in my portfolio by just duplicating another page and replacing the content, this was working until I went into the CMS section and tried to re-arrange the layout, then I had the same issue with the page content disappearing then flashing in preview.

Ok I will give this a shot on the project I archived.