Custom fonts not loading on PC

Hi All,

I have an specific issue with a custom font not loading on PC’s.
I can’t find a post which matches so starting a new one.

The custom font that I have uploaded (Hirgino Maru Gothic) seems to work in all browsers when viewed on a mac/iphone but fails to load (it loads as a fallback serif font) when the website is viewed on a PC (the problem occurs across multiple browsers).

The website is live here and the font issue occurs on the text ‘works’, ‘info’ and ‘Rebekka Hilmer Heltoft’ – https://www.rebekkahilmerheltoft.com

A little more context:
I have tried uploading all the different font file types: woff, woff2, ttf and this didn’t seem to help. When I first uploaded the custom font I was able to see it in the Designer. When I discovered the issue I wanted to upload the font from scratch with a simplified name but now when I upload the file webflow seems to not recognise it and displays it as the fallback serif font in the Designer. O have tried uploading some other custom fonts and the same issue seems to occur, which makes me think it is not an issue with the font file but instead something else.

Let me know if any of this needs further explanation. Any help would be much appreciated!


Here is my site Read-Only: LINK
(how to share your site Read-Only link)