Streaming live at 10am (PST)

Cursor doesn't change to pointer – Bug?


I set the cursor to become a pointer over a link. But this doesn’t happen, even if I increase the z-index (and the link opens up so that shouldn’t be the problem).

On another website of mine the same problem occurs, although it worked before. Is this a bug right now? Is it the same for you?

I also tried it in Safari and Chrome…

Hi @Sonja,

Check your layer stack, the link is probably under another layer but doesn’t show on the canvas when hovering over. Remember, in Webflow in the Navigator tree:

  1. The “higher” in the layer navigator list, the lower you are in the stack.
  2. The “lower” an element is in the list, the higher it is in the stack.

Even if you add z-index, the Interactions will follow the layer stack automatically. You can’t animate z-index, so you have to move your elements into position in the Navigator.

Think of it like this; Using the layer/tag. The closer an item is in the list to the Body - the “lower” it is, in the stack.

Be sure to keep tabs on your layers. That might be the cause. Hope that helps :slight_smile:

Thank you! But it works now, without me having to change something… so I guess it was just a short term problem

No problem, I hope that helps in the future. Have fun!