Streaming live at 10am (PST)

CSV Import doesn't allow to map fields - then freezes

Hi there!

I’m trying to import my first CSV file into Webflow and am rather stuck. I’m on a paid hosting plan so should be able to import.

The CSV is exported from Mac Numbers and has 178 items with 4 fields each and is only 16kb in file size.

The Collection is called “Listings - Basic” (it’s a basic business listing)

When I go to the collection and import the CSV, all appears to be working at first (it displays the preview and header row):


When I hit continue, it shows the fields on the left but doesn’t let me do anything in the drop down, I can’t match to field, or create a new field - nothing opens up on the right hand side like it does in your training video. Then every thing seems frozen, I can’t cancel, I can’t return to the dashboard and clicking nothing responds at all except closing the browser completely and logging back in. I’m using Chrome.

I’ve tried numerous times, I’ve tried deleting irrelevant fields from the CSV and don’t know how to get it to work. I hope it’s something I can fix easily and keen to hear what I’m doing wrong.

I hope I’ve provided enough info, thanks.

Here is my public share link:

UPDATE: I have managed to import the 178 items only after deleting multi-reference fields (which I used for categories) from my collection and any templates and pages that used multi-reference fields. This was a big thing to do as I spent quite a bit of time working out how to display these things on the page correctly leaving my import til last. Once I deleted the multi-reference fields from the collection (and pages), I was able to import the CSV and all items came through (minus my categories) - and now I will manually assign each item to their categories. Quite fiddly but not end of the world for me, this would be a problem for larger imports though.

I read that there was an issue with multi-reference fields and CSV’s, but I didn’t realise you could not import the CSV file at all if one was set up, I thought it would just not allow you to match that particular field type and you could import the rest of your data ignoring the multi reference. So this assumption was wrong, be careful… you can’t import ANYTHING if your collection has multi reference fields included in it’s set up. You have to go back and add the multi reference field AFTER you have imported all your data. … well that’s how it happened for me anyway :slight_smile:

Hi @Kulsha

Thanks so much for posting about this and letting us know you found a solution.

I will still investigate this with the team, though to ensure the issue is addressed.

Thanks again for bringing this to our attention! :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.