Collection list wrappers search index settings do not work

I just noticed in several of my projects, that collection list wrappers have a standard setting, that excludes their content from search engine indexing: A small box to tic on/off at the bottom of the element settings of the collection list wrapper called “Exclude Collection List Wrapper’s content from seach results”.

It is weird enough that this is turned on as a standard setting, as I have a lot of relevant content in collection wrappers. The big problem though: It does not work if I turn that off. If I turn it off, change to another site and come back to site with the respective collection wrapper later and open up the element settings, it is TURNED ON AGAIN. The setting does not seem to get saved…

Pleas help! Does anyone have a similar problem???
@webflow team - this should be working!

Screenshot from a collection wrapper element settings for a faq section. Setting is at the bottom

Did some more testing. The Problem persists no matter the browser I work with.

Hey Martin, you forgot to share your project read-only link, so I can’t take a look.
However first thing I’d do is walk up the element hierarchy to the parent, grandparent, etc. and see if that setting is applied there.

You may be seeing an inherited setting.

Also this has nothing to do with SEO, that setting relates only to Webflow’s internal site search feature.