CMS Projects not sorting by selected project number

I can’t get my projects in CMS to order by their selected project number. Every time I create a new project, even if I order it to the bottom, it stays at the top of the list. How can I make the projects order as I choose? See screenshot for what i’m dealing with.

If you’re just trying to sort the view inside of the designer, click the column heading to sort on that column.

If you’re trying to sort your collection list, configure your collection list settings to sort by your numeric sequence field.