CMS Colletion items GONE

I added a new Collection for a Client’s website. When I tried to add the text and picture as Collection items, Webflow gave me an error message saying that “Element cannot be placed in a collection list wrapper” (The element is just text). I made a new blank project as a test and added a collection list, and the same thing happens. I tried to add… anything. It’s not letting me add it. I created a separate page and added a collection list to the container to test it in a more simple way. It’s not working. (Attached screenshots). I thought maybe there are updates or changes to the way CMS works. I tried to compare the CMS Collection template content to the new test project and anything inside of the collection list is gone. The whole design (inside of the added collection list) is now empty. Am I the only one having problems with this? Is it something in our account? Any changes in the way CMS items should be added? (I just add the element to the spot by dragging it from the elements menu). I’ve been using Wenflow since 2016, and this is the 1st time something this strange happens. Any help is appreciated. Plan B is writing an email to Webflow.

Here is my public share link:

I just did a quick test on my end and it looks like you’ll need at least one collection item before you can start adding content to the collection list. I honestly can’t say whether or not this has always been the case since I tend to always start with some content, even if it’s just placeholder.

Try creating 5 dummy items within your blank collection list and see if you’re still having issues adding content to the collection items.


I tried that. This test site is a copy of the client’s site. on the client’s site we have 2 collections with items (one of them with more than 200 items). The collections being empty would not explain why the items on the dynamic list were gone. I created a few dummy items on this one too, but, just as the other site, it makes no difference.

Hmm, that seems strange. I’m able to add elements as expected now that your read-only link collection has items within it.

If you’re seeing something different on your end I would reach out to Webflow Support (if you haven’t already) as it could be a bug. It may also be beneficial to test this out in an incognito window with all of your extensions disabled to rule out any conflicts.

Sorry I couldn’t be more help :confused:

I started to work. I didn’t change anything. Suddenly it worked. I guess I will never know what was wrong. Some glitch maybe? The content of the Product template is back also (that was in the client’s page. it was totally gone.)

Thanks for the help. I appreciate it.

1 Like

Sounds like a little bug but I’m glad to hear it’s working again for you!

I’m having this problem now too. Can’t move any content into the content wrapper (anywhere in it) without getting this message.

FIX: check your filter on your CMS. I had a typo in my filter and so there were no items. Turns out you have to have items before you can move / put content there