CMS Collection Parent Folder option is missing

Something is wrong with our CMS collections today. Suddenly the “Parent folder” UI option is gone.

I have a collection list on a static page. The links from that collection list links are suddenly not working because they’re missing the parent folder portion in the URL. When I look at the CMS Collection’s settings, they still seem to be in the URL, but the option of setting the parent folder is no longer visible on any of my collections!

The static page on Free CE credits for therapists, psychologists, and counselors - Joon is linking to things like https://www.joon.com/continuing-education/obsessive-compulsive-disorder, but the actual page is still at Assessing and Treating Obsessive Compulsive Disorder - Free CE Course - Joon. So it’s just the link in the collection list that is borked, plus the missing UI control…

Yesterday I had to restore our site due to unrelated issues, so I am aware that changes collection IDs. I can’t see any reason why that would cause this, but mention it since it’s proximal in time.

Can you help? Anyone else having similar issues?


Here is my public share link: [LINK]1
(how to access public share link)

Are you sure you’re not looking for the Parent Folder option in the Collection Page settings?
image

I went to the collection, clicked the cog icon, and am looking at those settings.

I just went to the template page for the collection and now I see what you are saying! However, the control is there and set correctly, so I still don’t know why my page is broken. :smiling_face_with_tear:

Hi Corinne, why do you think it’s broken?

https://www.joon.com/for-therapists/continuing-education/neurodiversity-affirming-therapy

Sorry my explanation wasn’t more clear.

The hub page is up and working. The child pages are working, too.

But the links from the hub page to the child pages are all broken. It’s a collection list on the hub page and it’s set up correctly, so I don’t understand what’s wrong. I was previously working and then stopped. For some unknown reason, the URLs in the collection list are missing the /for-therapists/ part of the URL path when published. It was working and something changed.

:laughing: From this part of the description, my immediate guess is that this sounds like a localization mechanic conflicting and getting confused. It probably does not know what locale you are, and is interpreting that first path segment /for-therapists as being a locale.

Try setting your primary locale here and republishing.

So sorry, I wrote this long ago and it never posted…

Thank you so much for the advice! It turns out my colleague published an unrelated page several hours ago and that somehow fixed it. I wonder if there was a temporary bug in Webflow? So annoying to not know what broke, and then repaired, the issue.

I’m very grateful for your help. I will go ahead and make that locale change anyway just in case (plus I imagine it’s nice for SEO and general bot guidance)