CMS collection displays publication date and not creation date on mobile


for some reason the CMS collection of news items, which have a creation date, modification date and a publication date (which changes every time I make changes to the design and publish the site), will display the publication date (that is, the same date for all news items) and ONLY ON MOBILE. The normal site is ok. I cannot in my life figure out how to fix this. Please help!

Please provide a read only link to your project.

1 Like

here is my read-only link. thanks!

Your “Date” field (bound to the the “Paragraph 23” paragraph element) is a text field. Not a date field. It is bound to the Collection “Updates” on the News page.

Bindings don’t change across breakpoints on the same collection list.

Viewing the published URL for that page shows that it is identical to the designer preview.

Thanks for answering. The preview in the designer indeed displays as it should, that is, with the text that appears in the date field (which is indeed a text field and subject to the author’s decision on which date to enter). And the desktop version does display it correctly when published, inside the designer as well as online.

My problem is with the mobile version. While it does display it correctly inside the designer, when I publish my site and look at it through my phone - it shows the publish date (same date) for each update item of the collection, and not the text that the author entered. And this happens every time I publish my site.

I don’t know why this happens or where I can toggle this from within the designer. It has to be something with configuring the display for mobile to show the text of the date field and not the publishing date, but I don’t know how.

I will greatly appreciate your assist! I’m really at loss here.

here is a screenshot of the published site as it appears on my phone.

You are seeing a cached version of your webpage. Not the current version. You need to clear your mobile browser cache.

I appreciate your help, but this really isn’t the reason. Otherwise it wouldn’t have updated yesterday’s date - July 14. To double check, I cleared my cache and it still appears the same.

This must be a settings thing. Can you maybe direct me to where I can configure the date for items in the updates collection, so that it takes the creation date and not the publication date? Or simply displays the text in the date field as it should, without pulling any other data and displaying it?

for that matter, I would like to be able to write in the date field “Junvember 85, 3012” and for it to display that date. Not creation date, not modification date, not publication date, and not the date of the national French holiday Bastille day. Just the text. thanks

also how could it be different in mobile and desktop?? it honestly makes no sense to me. And I’m using incognito on my phone.

Here is a screenshot from a no-cached network infrastructure and device / machine.


so so strange. Thanks though, you gave me some peace of mind. Sorry for being so persistent about this.

I am not sure where your test environment is, but it is possible that caching can occur between you (your device and network) and the Webflow cloud architecture.

I maintain multiple environments from which to test to avoid or isolate these types of issues.