CMS Collection blog posts not loading

https://preview.webflow.com/preview/pinksquid?utm_medium=preview_link&utm_source=designer&utm_content=pinksquid&preview=6c0d534000957ac29feeab5a2e7be6e8&pageId=64da535933813d37915c25ab&workflow=preview

I have created a CMS Collection for my blog posts and, although i have published them, none of them load - instead the url displays my 404 error page. HELP!

See example www.pinksquid.com/blog/recre8-our-new-innovative-asset-platform

Hey Marcelo, you need your readonly designer link in order to get assistance here.
Most likely you have publishing turned off under your CMS page’s settings.

Thank you, Michael! Here is my read-only link. All other CMS collections pages work, only the blog (Insights) doesn’t seem to work. I’m tearing my hair out!

https://preview.webflow.com/preview/pinksquid?utm_medium=preview_link&utm_source=designer&utm_content=pinksquid&preview=6c0d534000957ac29feeab5a2e7be6e8&pageId=64da535933813d37915c25ab&workflow=preview

Like Michael mentioned, go to your CMS pages publish settings and turn it on. He gave you the answer. I’m sure he’s got a screenshot queued up somewhere, seems to be a question asked, and answered by him, often (not the most intuitive of features).

Is this CMS publish settings within the CMS collection itself or in the general site settings? I can’t see any CMS publish settings. If you look at the image I attached above, you can see it says PUBLISHED at the top right. I have used the PUBLISH in the SAVE dropdown option for each blog post, but it still doesn’t work. And I have tried creating another CMS blog collection and it also doesn’t work. I can’t understand why. All the other collections work perfectly well.

Thank you, Michael, that solved it! ChrisDrit added some screenshots which showed me how to toggle that setting and it’s all working now. Thank you very much.

1 Like

Hi can you you help me i have same problem