Clone Site not adding to workspace

Hi Webflow team and community.

I’ve been having issues the past few days with the Clone Site option in both the “Made in Webflow” section and my own account. No matter what site or made in webflow site I go to. When I click on Clone Site it just takes me to the Create a New Site page and nothing happens. It doesn’t get added to my workspace or sites and nothing happens. I was able to get it to work one time yesterday only because out of frustration I clicked on Clone site over and over but today I can’t get any site no matter where from to Clone to my workspace. It just takes me to the New Site page and nothing happens.

Has anyone experienced this?

I’ve tried clearing cache
I’ve tried using a different browser entirely.
I’ve signed out, signed in

Thank you.

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Having this same issue.

Did it start working for you again? Cause a couple hours later I came back and haven’t had any issues since. Maybe it was a temporary issue on Webflows end.