Streaming live at 10am (PST)

Client editor not loading or giving Error "Something unexpected happened!"

Hello All,

Just started happening today Jan 21, 2021

One of my clients nor myself are able to log into the editor. My client is getting the red “Something Unexpected Happened!” error or just seeing the “Edit Site” loading animation spin round and round.

I’ve asked them to try:
in multiple browsers
Incognito modes
Clear thier App Data
Clear their Cache
Rebooted for the hell of it

I’ll delete their user and reissue invite but the strange part is that I, as the site admin, also cannot use the editor.

From the designer if I choose to enter editor mode I get logged out with a session has expired error pop up and a “Something unexpected happened!” error in the background.

Any Suggestions?


It happen to one of my clients. What i found was that one record on the CMS was corupted. I removed that record and all was fine. Ask you customer what they where doing when it happend

Hi Janne,

Thanks for the response. Unfortunately I still can’t get into the editor.

I went through all the CMS Collections paying close attention to the ones that were last edited but nothing looks out of the ordinary.

I’m not sure how I would tell if a record was corrupted.

I did notice however that a few hidden elements on pages were being displayed even though they still had my “hide” class on which I though was strange. So I deleted them all and any collections that may have been linked but that did not work either.

I’m still troubleshooting and still waiting on my support ticket to get answered.

Thanks for the tip though I’ll keep poking around the CMS.

Appreciate it,

Hi @geo-k ,

Did you manage to work this out, please?
I am having the same issue - neither my client nor myself can log into the Editor any more. He is getting the “Something unexpected happened” message, while I am getting “Your session has expired, please log in to use the Editor.”

Like you, I don’t see anything wrong with the CMS items.

Thank you!

Hey @Pataka,

I did yes with the help of @JanneWassberg and some support from webflow I was able to figure out that there were 2 instances of jquery loading. I was originally loading it via custom site code to accomplish some tasks and everything was working fine. But as of 2 weeks ago the editor broke so my assumption is that webflow is now loading it by default because all my modifications are still working without me explicitly loading jquery.

All I did was comment out the script and viola editor working again as are all my original functionality.

I hope this helps you in some way, I’m no expert so good luck and reach out to webflow support they are exceptional with the help.


Brilliant, @geo-k !!
This has worked for me, too! Commented jquery loading, and all is good!

This might be an important piece of information Webflow could post somewhere for everyone…

Thanks a lot, George!

Hey that’s great news @Pataka
Glad that worked for you too!


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.