Class "button 2" visible in CSS but can't find in in HTML Code or delete the class - I'm frustrated

Hello together,

I have a class “button 2” and a subclass “accept” which was probably part of the finsweet cookie banner. This was included for testing. Now another cookie banner is used (ccm19) but I can’t get the old classes deleted and I can’t find the settings where I can delete this class! Neither in the code of the website settings nor in a HTML element is anything linked. Therefore urgently ask for help, because these elements still use the google standard fonts and I want to remove them.

I deleted everything from the site (with previous backup) to test. The class “button 2” remains although I had deleted everything!

In the CSS code the entry of the “button 2” appears but neither in the HTML nor on the page in the WebFlow editor I can delete the class or find the element the class is linked to.

So i need your help to figure this out, unfortunately I dont know how to solve this. (In Site Settings no finsweet cookie link is set any more! In the settings on the page is also nothing set and so on)

2022-10-03 09_37_35-Webflow - Copy of Copy of  BLANK

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hey Sven @OnFire,

this seems to be some kind of bug. I tried to figure this out with @Ninahons about two weeks ago. She came up with a pretty smart solution, which I am going to link below:

Please try this and let me know if this helps.

1 Like

Hi Julian @choreus ,
so i created a new Div Block and selected the Class “button 2” and “accept” where the old Style font “pt sans” was selected. I changed it to my “Robo Custom” font. After that i reloaded the page and checked the .css File under . Unfortunately .button-2 and “accept” are still set to PT Sans?!
2022-10-03 12_49_30-https___uploads-ssl.webflow.com_630e72fc0ea2424e19753ff3_css_blank-05b906-7933c4

Google font checker from this Website is showing me 5 Items even:

In the CSS File that is generated for the Page only “button 2” and “accept” are in PT Sans Setting. I dont unterstand that

@OnFire, okay. What exactly do you mean by you reloaded the page? Are you hosting with Webflow or are you exporting the code to host somewhere else?

Also, are you checking the .css file inside the browser with developer tools or are you opening the file locally?

Can you share the link to your published site?

I’m Hosting on Webflow. Here is the Link to the Page: (it’s safe to share or?)
I’m checking in the.css file inside the browser with developer tools :slight_smile:

Best wishes!

@choreus i think now it worked to exchange the font. Somehow in the “Desktop” view it was changed correct but in the “Laptop” view the “button 2” and “accept” Class hat still the Style “pt sans”. I changed it also - now the css File seems to be without the old “pt sans” font :slight_smile:

@choreus now the external google font checking is also telling, that no external font is detected :slight_smile: - woop woop (im haaaaaaapy)

@OnFire Yes, it’s safe to share this. Looking at the published code is sometimes necessary to find the solution. Thank you!

You have created a combo class button 2 accept and changed the font family on that. Any changes only affect this combination. Please add a new div, only add the class button 2, change the font family and try again.

Edit: It’s good to hear you were able to solve it.

1 Like

Ok - i changed it already on both. The combo class and the button 2 class itself. Now no webfont.js File is loaded in the “network” tab (browser developer tool) and no element with “pt sans” is shown at the font checker website anymore. So i think you provided the right solution! Woow Julian - your are my hero !!!

1 Like