Can't remove guest editors

I have a site plan with the option to add up to 3 guest editors. I’ve added one for testing purposes earlier, the second one will not become an editor.

How can I remove guest editors?

Roles & permissions | Webflow University shows it, but it’s not available for me.

And no, I’m not planning to use a workspace plan.

Did you go to the Site settings and checked on the Members section?

You are the owner of the account right?

Yes, I’m the owner/Site admin. Check in the site settings where member(s) and guest editors are listed.

So you tried clicking on that three grey dots on the side and Click on Remove guest editors? Then it will also ask you to type REMOVE.

1 Like

Oh, wow. The “…” menu is hidden for me for whatever reason. Works in another browser profile. Thx.

1 Like

Great, and you are most welcome.

And as it seems you’ve found your solution, can you please mark this post as solved?