Can't import images

Hi guys! :wave:t2:

I have a customer who wants more than 50 logos to be displayed. So I put them on one of my FTP-servers and generated a CSV specifying each pictures name and location:


But when I import the CSV (expecting Webflow to fetch the images) it tells me “The imported data isn’t compatible with this field.”

I think I’m doing sth wrong. How’s this supposed to work?

Thank you :pray:t2:


I second that. I’m also having issues when setting up a Collection to import an image via CSV and bind the image to a CMS Collection image field.

I’ve been capturing data from Jotform. Uploaded images are hosted on jotform. I have the image URLs; not able to bind them to the image field in the Collection. The field is there, greyed out/ not selectable.

Tutorials looked straightforward, what are we doing wrong?



I never found out how to do that. Did you?

Yeah I got it to work. Post a link to your CSV. If even one image is not formatted correctly the entire import won’t work.

1 Like

Hey @croquisKid … I’m coming back to this topic. I never got it to work, but now I really need it for a collection of over 600 items. I hope you have some new input for me, because I already spent 2h on this now… which should be a nobrainer.

Your last comment was to make sure, not a single img URL is wrong. Well, I reduced the CSV to one item and tried all kinds of different URLs. Those which were already hosted on Webflow elsewhere, or now this:

This is the file:

Equipment - Articles,,,,,,,,,,,,,,,,,,,,,
Name DE,Slug,Collection ID,Item ID,Created On,Updated On,Published On,Name EN,Image,Number,Preis,Related Article Slug (optional),Produktgruppe #1,Produktgruppe #2,Produktgruppe #3,Produktgruppe #4,Produktgruppe #5,Produktgruppe #6,Produktgruppe #7,Produktgruppe #8,Produktgruppe #9,Produktgruppe #10
1-Weg Ladekabel,1-weg-ladekabel,5d494f0f3cf49ee936ee3b72,601aad6a67c2db259a104e56,Wed Feb 03 2021 14:04:26 GMT+0000 (Coordinated Universal Time),Wed Feb 03 2021 14:04:26 GMT+0000 (Coordinated Universal Time),Wed Feb 03 2021 14:11:20 GMT+0000 (Coordinated Universal Time),1-Way charge cable,,134643,75,,,,,,,,,,,

I still get the same error message: “The imported data isn’t compatible with this field.”

Thanks a lot for having a quick look at this!

Solution here: