Can't click on anything on editor

Hello,

I’ve been having an issue with the website editor and designer. Since last friday I’m not able to click on anything in the editor, I’m not able to look for anything in the product search bar, etc… I can’t even click on “go back to site” when I’m in the editor. I already tried deleting website cookies, tried it on incognito mode, on another browser, on another computer… tried deactivating any browser extensions I have as well. I asked another website collaborator to try it and they weren’t able to click on anything either. I’ve also had somewhat similar issues last week, I wasn’t able to add a main image to a product. The option wouldn’t even show up and it was only for that product, so I had to remake it because of it. I’ve only used webflow for a while and I’m wondering if webflow ecomm will be a good long-term option for us? This issue has put a damper on some plans I had for the website. I already messaged customer support and they didn’t know what the issue was either. I love webflow so far, it’s very intuitive and easy to use than most of the tools I’ve used before (I’m definitely glad to switch from shopify). But I’m worried if these will be recurring issues, since it has been going on for over 4 days now.


Here is my site Read-Only: **[LINK]

Here’s a Loom video showing the issue: [LINK]