Streaming live at 10am (PST)

Can't Add Link in Webflow, but can in Editor

I’m trying to add a link to some text on a Webflow page.

When I select the text, the popup appears and I can format the text with Bold, Italic etc, but when I click to add a link the popup disappears after a second.

I can add the link using the Editor without any problems.

I can add links in Collections items without a problem too, it’s only pages which are the issue.

Any ideas what’s causing this?


Is it in a paragraph or a Rich Text Block? When I select a word inside a paragraph and choose link the pop up disappears but the word has now change to a link and you can use the settings panel or cog.

Does this help?

Thanks for the reply @jorn

Unfortunately it doesn’t do anything at all. The pop up disappears and the word hasn’t changed.

It’s a paragraph in a rich text block.

To make it even more confusing, if I try and add a link within a paragraph that I’ve already added a link to using the Editor, it does work. But not in any other paragraphs.

Hmm ok…

I can’t reproduce this at my end, it works as expected for me. What browser do you use and can you try it in incognito mode?

Hey @jorn, I’ve tested it in Safari and Chrome, unfortunately incognito mode doesn’t make a difference.

Here’s an example of what I’m seeing:


I see that it’s a list item and I just tried it and I cannot reproduce this. Is it just this project or other projects as well?

I recommend you to send an email to support so they can have a deeper look on what’s going on. Send them info on what you have tried and that gif so they easily can identify. Also send the read only link. Good Luck!

@cyberdave Can you help out here?

I’ve created one other Webflow project and I don’t remember the same issue there.

I’ll get in touch with support, thanks @jorn.

1 Like