Can't add imgs to assets

I started a new Lesson- Full site build—downloaded course assets. But when I want to add the first image I get this msg: Your upload failed because of a filename error. Filenames should be 100 characters or less (including the file extension) and avoid special characters (e.g., #, (), ').
The image name is Feature design.jpg
I can’t move. Not the best start I guess… I tried to upload it via assets and images…
I also tried to do so on my iMac and MacBook but the same. The only difference is that on MacBook the Webflow designer screen reacted when I tried to drag and drop an image but on iMac no reaction to it at all…
I have already built one site on Webflow- the Calendar site for beginners and passed the 101 exam. Thank you, guys

UPDATE!!! I did add the image (from the downloaded file on my PC) straight into the grid cell (grid cell with a div inside) and it worked!!! How strange. It even appeared in my Assets folder. Well I think I have just found a way around ufff