Streaming live at 10am (PST)

Cannot unhide an element

I seem to be encountering a bug whereby I cannot unhide an element. I have set some paragraph elements to hide on mobile landscape and mobile portrait, but when I go into the settings and toggle them to show again, they do not appear. However, if I then toggle the element to hide on tablet view, it will display again for mobile views.

Has anyone else run into this problem?

Can you please share your project’s public link so it’s easier to understand your issue?

Learn how to do it here: http://help.webflow.com/sharing-your-public-webflow-site-link

Thanks, here it is:

https://webflow.com/design/big-wedding-checklist?preview=c25bbe66ef1d1e920bcec1fd9e3c26da

I’ve lloked all pages at all devices and everything seems to be there. Where’s the issue?

Thanks for having a look, Vincent.

The problem is on the wedding planning checklist page. On mobile views, I hid the text that is located beneath each h4 checklist heading. I now want to unhide it and have changed the settings so that it is no longer hidden, but the text does not show.

I forgot to mention the content that I’m talking about is on the 12 to 18 months tab

It seems it works fine here… does that make any sense to you? https://v.usetapes.com/VW9Eu5fU8i

I have to say 9 vertical tabs on mobile don’t make any sense design-wise. Users will never figure out where to watch after clicking on a tab.

Thanks for the feedback. Not sure what to do with the tabs yet on mobile vertical view. I can’t watch the video, it gets stuck whilst uploading.

watch it now it had to upload before

It still says it’s being uploaded and doesn’t play. Does it work for you?

Not any more.

But well it was easy to unhide your blocks. Select the block in the desktop mode, switch to mobile, click on display:block, and it appears.

1 Like

Brilliant, thanks Vincent. If you’ve got a donate link anywhere I’ll buy you a coffee :smile:

1 Like

Thanks, I love coffee! I don’t have such a link but if you travel to the French west coast we can seal this deal ;-D

Just out of curiosity, what was your failing method when you first tried to unhide the text blocks?

Sounds good, I’m overdue a trip to France anyway :slight_smile:

I had set the elements to only appear on desktop and tablet. To do this I had used the visibility settings under the settings tab for each element. It was a silly way to do it anyway- it makes more sense to set the element to be hidden under styles, then you only need to set it once. After that I was unable to go back into the settings tab and change the settings so that the text blocks would show on mobile views again.

maybe I don’t understand the problem

seems to work fine for me

see video

http://quick.as/vkXxT9Jb

I’m not sure, perhaps I had set the elements not to be visible using the style attribute, although I thought I had done it in the settings tab.