Cannot restore backup due to server error

I’ve been working on a project on webflow. Making backups regularly.
Last month I got a mistake so I needed to restore to previous version.
When I tried, I got three times the error “Ops, something was wrong” and cannot access the Designer page.
Could not load index page DOM
So After three times, finally worked.
But today happened another mistake and need to restore again.
Seems not been working at all.
Tried multiple times with same result, “Ops, something was wrong”
Using console to inspect the call, call are returning 504 (GATEWAY_TIMEOUT)
How can I overcome this issue? This is a temporary issue from server? Must wait?
What is the cause of this issue?
It’s a large project, but no think there is an hard limit about been able to restore a project.
Any tip or help I’ll be welcome.

1 Like

After tried about half hour fighting against the project deadline, finally worked, but every time I need to restore an project for this customer, I’m getting the same problem. Can’t trust restore those projects. This is a know issue and will ever work after tried multiple times? There is any way to take a look on this issue to prevent to happen again in the future? Got feedback that this happen while another developers working on too. We Didn’t found any question talking about this on the forum. Maybe worth keeping the topic.

I am getting the same issue on a large site with preview backup. I did get some support feedback saying they could duplicate the issue but backup should work. A risk I did not take. They said site was large and that may be the issue. I asked if Webflow was not the right platform for large sites and was assured it was. Still have some concerns. I ended up redoing work rather than trust the restore. I am also exporting the code & collections locally | Just in case.

I have the same issue. Have you solved your problem?