Cannot publish via Editor or Designer

Hi there,

The changes I make in editor do not publish through to my live website. When I click ‘publish’, it does say that the changes have been made successfully, however my live website does not reflect the changes. I’ve tried publishing via Designer as well, with the error message of not being able to read the property of ‘getIn’.

You can find the live website here:

I’ve emailed support with images of my process.

Here is my site Read-Only:

Hi @hansim,

Thanks for posting about this — it definitely sounds like odd behavior.

What sites are you seeing this issue occur in – only this project or multiple projects? When did it start occurring? Can you send me the site Read-Only links please?

Can you please try the following:

Could you also please let me know what browser version you’re using by sending me your information from this page?

There should be a small share link when you visit the page which you can send to me.

Thanks in advance!

Hi there @Brando, thanks for your response.

Here is a screenshot of my console in incognito mode:

I’m not sure what it means - but it might have something to do with the background image? If you know the way to fix this, could you talk me through it in layman’s terms, please? :slight_smile:

This issue is only occurring in this project. It started occurring last Friday, mid-morning, after I made several changes to my site in a row in Editor.

The site Read-Only is: - I had it posted above :stuck_out_tongue:


It is telling you that it cannot access the property innerHTML of null . In other words, that year is null and that you cannot access a property of it.

Basically its telling you your element does not exist. Where are you getting ‘year’ from?

Thanks @Poliigon, I think it might have to do with my custom code in the Header - to do with the year - but I’m not sure on how to rectify it.


I changed the code to: document.getElementById(“year”).innerHTML = new Date().getFullYear(); and that hasn’t fixed it.

Any idea on how I can fix it?

I think we had the year there so it would automatically update down in the footer - for the copyright.

if it were me, I would delete the text box and where your copyright is as of now. not the footer just the textblock

add embed then paste <? php echo date("Y"); ?> there with my company name. and then copy the element to each page

I deleted the code in the custom code account settings and published:

Publishing from the designer had the issue as well:

I think I’m still doing something wrong.

@hansim I still is the code in the site.

That’s because it won’t publish any changes @Poliigon

@hansim hit unpublish then republish

Now the website isn’t published at all

try to publish to the io domain

Still the same issue :frowning:

If anyone would like to help by doing some remote work, please let me know

Hi @hansim

Thanks for your patience.

Our team was able to find the root cause of the issue and deployed a fix – can you please test this on your end?

I was able to publish it! Thank you - what was the issue in the end? And do I contact you if it occurs again?

1 Like

Thanks for letting us know @hansim!

The team discovered a bug here that was a regression from an update we made to the CMS. We’ve uncovered the bug and pushed a fix for this though and it shouldn’t crop up again.

If you do see it again though, or any other odd behavior, don’t hesitate to reach out to our team directly:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.