Buttons don't work on the user's first access

Hello, I have a problem with some main buttons on my website.

Problem:

On the Home Page, I have a few important buttons. However, it happens that when accessing the page for the first time (user’s first access), the buttons do not activate/work.
After refreshing the page or logging in again, the buttons work normally again.

What I’ve already tried:

  • I have already tried to change and replace the buttons
  • I have already removed all button animations/interactions

Even so, the problem persists.

Can someone help me?

I’ll leave the link read-only, but I’ll tell you that in Preview mode the buttons work normally.

(Note: This problem only happens in the mobile version)


Here is my public share link: LINK
(how to access public share link)

Which buttons?
I’ve opened your published site and they all appear to be working fine.

All buttons, especially “I want to support”.

However, this problem only happens on mobile devices (smartphones/cell phones) on the first visit.

Ah, I totally missed the mobile note at the very bottom :wink:

The problem is that your Popup-section at the very bottom is obstructing it.
I haven’t deconstructed your code, but I am guessing you have some kind of modal pop-up that stores a cookie, which is why it’s suppressed later.

On first load, even though it’s not visible, it’s there in front of your button covering about 1/2 the screen. Because it’s fixed position, that whole area is “unclickable” no matter where you scroll in the page.

Thank you very much, I would never have imagined that would be the case.

Yes, not obvious at all.
It was tricky to find!

Hi,

Since the day you responded, I’ve been trying to understand why the Container interferes with the buttons when it’s hidden.

This doesn’t happen on the computer

You can see the display: block; is on the element’s style directly which in Webflow generally means it was put there by interactions.

99% chance it’s due to how your interactions are designed. Something like you’re showing the outer frame and hiding the inner frame, so there’s still a DIV ( just no visible content ). Or you’re using opacity 0% rather than hide, which might make it still exist.

I can’t tell you more would a bunch of testing and direct access to the interactions. If you get stuck you can direct message me and I can send you my rates, I enjoy debugging things like this.