Button Link in CMS Modal Isn't Advancing to Next Page

Hi All - I’m crossing my fingers that one of you generous souls are willing and able to help me out on this! Thanks so much for your time.

I’ve built a CMS site that allows users to click a CMS tile to access more information via a popup modal. The modal trigger is working, but here’s my problem…

When the modal is visible, there is a button in the bottom right corner that–when clicked–is supposed to lead to a another page on the site, the “Treatment Options” page. For whatever reason, clicking the button does nothing.

I thought that simply having the button linked to the next page would redirect, but it doesn’t. I’m not sure if this is happening due to the way I have the CMS set up. Perhaps I need to have an interaction to get rid of the modal before advancing to the next screen? I don’t know. Any thoughts would be greatly appreciated!

Here is my public share link: https://preview.webflow.com/preview/pain-marketplace?preview=481a547a7bb99b8c48b82db81e0318af
Here is my published link: http://pain-marketplace.webflow.io

Hello @kdepop

Is your issue fixed? I just tried it and it works just fine:

Aaron - Thanks for checking it out man. Unfortunately, the problem is not fixed yet. The button works in the designer “preview”, but not in the live site. Check out this link: http://pain-marketplace.webflow.io/

I noticed that you have selected ‘open in new tab’ option. Can you please try it without it? Just out of curiosity and republish your site.

Hi Aaron - Just made the change you recommended. Still no dice!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.