Bug: Can't reset language code to blank / default in the project settings

I want to reset the language code to blank / default in the project settings. At the moment i’ve set it to the “en” language.

I deleted this “en” text in the project settings leaving a blank language-code-field. Hit save and published the website. This didn’t help. Webflow just resets the language code to the last used setting. Changing these settings to a different language (instead of a blank field) works fine. But changing it to a blank field doesn’t work…

When starting out a new project the language code in the project settings is by default an empty field. Why can’t I return to this default empty field?

Does this also happen to other people?

I tested this, looks like a bug to me too.

If you never set a language code, your project settings simply don’t have the lang property and it won’t be attached to the <html> tag. If you set it even once, and “remove” it by leaving the input blank, it will not remove the property and you won’t get rid of the attribute at all! It will always use the last existing one as the value will not be overwritten / removed.

imageimage

Exactly! Thanks for checking.
Any suggestions on how to get this resolved?

1 Like

You’d need to contact the support directly here:

Thanks for the effort you put in!

1 Like

No problem :slight_smile:
That’s what I’m here for

Well, you could create a new project, copy everything over and never touch the lang code :joy:

But if you have a paid plan, custom domain set up etc, etc it could be a pain…