Blogs: Links not showing inline as default

Hey everyone! Wondered if someone would be kind enough to help. I’m currently facing an issue with blog posts where any link I add in the CMS automatically has a return before and after rather than being in-line, meaning any link I add just shows on its own line. Any ideas how to fix this?

I’ve added a screenshot to help show what I mean.

@LogoGeek welcome to the forum!
Could you share a read-only link? That way we can have a look. Here’s how https://university.webflow.com/article/sharing-your-sites-read-only-link

1 Like

Thanks @sarahfrison - here you go. If you navigate to a single blog entry you’ll see what I mean: https://preview.webflow.com/preview/logogeek?utm_medium=preview_link&utm_source=dashboard&utm_content=logogeek&preview=fa3e89702d355dc324199c1109ad052c&mode=preview

@LogoGeek now this was an easy fix :slight_smile: . Seems that all your links are styled to be ‘display: block’. The RTE element, when an element isn’t explicitly styled within the RTE, takes its style settings from the ‘all’ elements so ‘all links’ in this case.
Either you can change your ‘all links’ to be display: inline or style links within the RTE.
Here’s how to do that: http://somup.com/cqiql7ejGE

2 Likes

@sarahfrison Wow Sarah! Thank you so much. Amazing of you to do that :slight_smile: All fixed!!! :smiley:

1 Like

@LogoGeek thanks :slight_smile: . That’s what we’re here for. Glad it worked out :slight_smile: