Streaming live at 10am (PST)

Assorted Open Graph validation issues

I’ve read several posts on the topic but am yet to find an answer to my specific issues.

Twitter Cards
ERROR: Fetching the page failed because it’s denied by robots.txt.
I have added: Sitemap: in the SEO tab.

Author and Publish date are missing from the Linkedin checker.

ia:markup_url / ia:markup_url_dev / ia:rules_url / ia:rules_url_dev / og:image:alt are all missing from Facebook but it appears those aren’t supported.

Can anyone suggest anything else I can try specifically with the Twitter Card validation?

With thanks.

Hi @Herbal,

When sharing the url with twitter validation, it should be done using the custom domain. You have shared the domain and when that opens you can see the root domain added to the sitemap.xml:

Shared with CloudApp

The root domain can only be set as the default domain if you are using a CNAME/ANAME record on the root domain to point to

If you are using DNS A Records to point the root domain at Webflow IP addresses instead, then the WWW domain need to be set as the default domain in Webflow, see how to set the default domain: Set a default domain | Webflow University

Both domains need to be added to the hosting tab like: (with the WWW domain set as default if the A Records method in DNS is being used).

After making changes, republish the site and then the share should work correctly. It sounds like the A Records are being used, the root domain is set as the default domain, or the WWW domain has not yet been added to the custom domain tab of project settings and set as the default domain.

Side note, the domain has robots.txt instruction to deny site indexing by default, if you actually wish to index the domain, you can do so by disabling the setting to prevent indexing on the seo tab of general settings:

Shared with CloudApp

I hope this helps

Super helpful. Thanks @cyberdave

I’ll let you know how I go.

1 Like