Streaming live at 10am (PST)

Apostrophe in Collection Field Shows "'" In Embed

So I have a collection item that has a field like this: https://i.gyazo.com/2613274d0a99edfb5e03c3a324367aa0.png

And I put it in embed: https://i.gyazo.com/c18e8699fdf842aa314968c829755f07.png

But when I go to the page, the apostrophe is gone and it’s replaced by “’”: https://i.gyazo.com/028cda2f584120838efe2f0e56d53bb3.png

Is there any solution to fix this?

Does anyone know how to solve this?

When Webflow encodes entities you have to deal with that in your custom code. You could set a let with the field contents then remove the encoding, then use the remaining string.

Thank you Jeff… Unfortunately I don’t know how to code so that doesn’t really help me.

Would it be possible for anyone to share their code if they fixed this issue?

I’m sorry for keep asking but I tried to hire Webflow Experts about this problem, but they all tell me “ask the community and they should be able to help you out”. But obviously I haven’t gotten any answer here yet.

If anyone could please help me with this, I would really appreciate it… I’m just stuck because I can’t get an answer and I can’t hire an expert either, so I seriously have no idea what I should do.

Share a published URL where I can view the rendered code. I can’t convert pictures to code easily.

Here’s a URL: test

Thank you.

I would use just comma delimited values in the CMS then in the code set a variable for each with the value from the CMS, then convert the string variable to an array using the split(',') method. Use the resulting value as the array in the chart script.

This works.
Shared with CloudApp

Maybe I misunderstood obut I changed the code like yours but it doesn’t fix the problem: https://i.gyazo.com/e20170f2ae4036bfccadec1fa65f329f.png

The problem is that the character ’ gets changed to “’”.

Share a read only.

I used no quotes (single or otherwise) for each element in the collection. Just comma delimited data. So Webflow won’t encode the string since there is nothing to encode. You can hire me for implementation.

Sorry I thought I already shared it: test

I deleted the quotes but that doesn’t work… As you can see “BackgroundColor” is written like ‘#174bd2’,’#174bd2’,’#174bd2’,’#174bd2’,’#174bd2’,’#f67c2b’ so I’m not sure how deleting the quotes can work.

Can I see the chart from your code?

The chart loads fine on my project. If you follow what I did you would have a working instance too.

A read only link is not a published link. Please include your site’s Read-Only Share Link with your question.

A read-only link allows the community to view your project without making any edits to it and help diagnose your issue or provide feedback.

https://discourse.webflow.com/t/how-to-enable-a-webflow-share-link/

Got it, here’s the read only link: Webflow - test

The chart is on “Product template”.

I don’t know how to code but I think I followed what you did on the page. But it’s not working on my end.

decode (webflow.io)

Your missing borderColorArray

Found it, thank you very much!