Anchors don't work when utms are added - solved

Hey Evereyone

When calling this page:

the anchors on the “jetzt kostenlose prüfen” buttons are working properly. and scroll to the embeddded heyflow form as desired.

as well the google reviews button in the hero element correctly scrolls to the reviews section.

adding utms to the urls as any of our marketing campaigns off course does comepletely screws up the anchors.

Instead of scrolling the url visible in the browser changes to:

So currently all of our anchors are screwed up as soon as utms are added - which means in all of our marketing campaigns.

The anchors are standard setup no custom code or anything.

Any ideas?


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

What is adding your UTM params?

In the example you gave…

There are two problems…

  1. There is no querystring; you need to delimit a querystring from the path with a ?
  2. The fragment is in the wrong place, it needs to be after the querystring.

The above URL corrected would be;

Hi Michael,
sorry if i was not clear in my post:

This is the link to the page without utms:
w w w . h e l p c h e c k . d e/lp/lebensversicherung-lp-neu-positiv-heyflow
using this link my anchors work.

Now i use this link with utms:
w w w . h e l p c h e c k . d e/lp/lebensversicherung-lp-neu-positiv-heyflow?utm_campaign=test&utm_source=test

the anchor links stop working.

Sorry for the spaces, wanted to stop the url from being reformatted

I am not trying to jump to an anchor from an external link.
I am just using utms for campaign tracking an want the internal anchors to keep working

Solved - was a problem with our internal skript forwarding utms on buttons