301 redirect is acting weird

So, I have a new blog I am working on and one of my blog post has a URL with .html added to the end of it. When you go to the .html version you get a 404 error. So I am trying to redirect from the .html version to the normal one. However when you visit the .html version it redirects to a weird URL (see below).

.html version:

Normal version:

Weird version:

I have no clue how this happened or how to fix it. To add to this, the orginal url was “best-pizza-in-dayton-ohio” I changed it to something else for a few days then changed it back. I think maybe the automatically created 301 from Webflow screwed something up.

Please help

Here is my site Read-Only: (Webflow - Dayton Pizza Reviews)

Hi Connor, working 100% fine here, my guess is that you changed your redirect recently and your browser has cached the old version.

Try it from a different browser or phone.

If you’re using Chrome, you can open dev tools, and under the networks tab you’ll find a little checkbox at the top “Disable cache”. When the cache is disabled, your browser will ignore the cache whenever devtools is open.

Great for debugging things like this.

Try that and let me know what happens interestingly there was another post from France about a similar problem, so if it’s persisting for you it might be some kind of CDN glitch. You’d want to video it and contact Webflow support.