Streaming live at 10am (PST)

100% wide div block not 100%

Hello all,

I am having an issue creating a div block that is 100% wide. I am trying to create a blog index similar to the escape template and I cannot figure out why the div i am using for the thumbnail is not working. keep in mind I am not using the CMS for any of this.

Here’s a video showing the issue.

I would show a public link if i could but this is a client’s site and a client’s account so I would rather not post it here but if a webflow staff member wants it, please message me


Here is my public share link: LINK
(how to access public share link)

Have you tried setting a height, or adding content inside it? That is only temporary until you put content in a div.

Yeah i tried, if i set a height, the width goes to 0. I do not want to put anything inside other than a background image. The reason I know something is weird is i am basing it off the escape template which has no content in a div set to 100% width. I have also done this in the past and it worked fine. I don’t know whats going on.


@DFink - Hi Dave, I just tried the same thing in the Escape template on a new page and I get the expected behavior of 100% filling the span of the column (minus the built in column padding of 10px left and right). Auto should also auto fill the width, which it how it initially appears to when you first drop in the new div - with no class applied.

Try creating a new class, or a new scratch instance of the columns. One of the two should sort it. Not sure what would make the class behave that way unless there is a transform applied or some strange inheritance issue.

Thanks guys. I figured it out. It was nested inside a link block that I had not set the 100% width to. My mistake. Thanks for your help!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.